Chop Shop Builds

Welcome to DezertRangers
Join the community. Register today for all the benefits of membership.
Register
May 7, 2008
5,024
141
63
phoenix, az
drove this turd all the way back from Willis' yesterday, then just now to the rock climbing gym and back with NOOOOOOOOOOOOOOOOOOOOOOOOOOT a single issue. On the freeway too the whole way!!!! yaaaaaaaaaaayyyyyyyyyyyyyyyy!!!!!!!!!!!!!

its like 52 miles one way to willis' (half way across the country) and like 24 miles round trip to my rock gym.

so like 75ish miles (mostly freeway) that ive gone with it CONTINUOUSLY running good.


:)(y):):):)(y)(y)(y):):)(y)(y)(y):)


making this post is going to jinx it for me, watch. hah
 

Attachments

May 7, 2008
5,024
141
63
phoenix, az
Well this thing still sucks.
Don't let me fool anyone by saying it's ready.

Proof with multiple videos of me hucking it like a man is the only thing anyone can trust.



Fucking alternator killed my weekend. Towed the - only good for looks (just like Loggie Bears truck)- thing all the way to Glamis and I think I got to drive it around camp fucking around on small shit for 25 minutes and that was it other than to trailer/off trailer. Which it couldn't even do ALL of that. Had to have Kalililililisters truck pull this turd on the trailer when we left.

My dad is pretty much over the motorhome exactly because of this weekend. We could of just hopped in the truck, unhooked from the toy hauler, driven to town and got an alternator, bam. Had it fixed. But we can't exactly do that in the motorhome. So he might be posting it for sale real soon and going back to a toy hauler that the buggy fits in. Probably 5th wheel though, he said.


Sooooooooooooooo.... Now that Loggies truck has an excuse for sitting parked, I had to take over his role of ALL SHOW AND NOOOOO FUCKING GO thing.


I'll get this thing faniggered out one day. Hopefully before I give this burden to Brogs' for his 16th bday......



BEWARE:
EXTREMELY SEXY C18 PICS OF MY HELLA HANDSOME SELF BELOW



Sent from my Moto Z (2) using Tapatalk
 
Last edited:
Likes: charlie_brown
May 7, 2008
5,024
141
63
phoenix, az
Well at least it looks good. Sorry to hear about the continual misfortune.
yeah thanks!!! id rather it look good and be sitting broke than be running great and look like dog doo doo honestly. hah.
ill get it figured out at some point! dealing with this does nothing but add to my experience with shit and adds to my knowledge of what and why and everything.

well.............. that is if i can remember it now. haha
 

nebf150

alignment guy here
Oct 23, 2007
3,378
30
48
32
westminster
ah that blows it let go. and sucks no one could go buy 1 for you trips like that sucks we have all been there. dont let it discourage alternators fail nails show up out of no where . take the good with the bad slap a new alternator in and put some miles on her...
 
May 7, 2008
5,024
141
63
phoenix, az
ah that blows it let go. and sucks no one could go buy 1 for you trips like that sucks we have all been there. dont let it discourage alternators fail nails show up out of no where . take the good with the bad slap a new alternator in and put some miles on her...
Ahhh. I probably wouldn't of let anyone go get one for me anyways, too stubborn and too much of a "I CAN DO IT MYSELF, ASSHOLE!" -er. Hah. Everyone was having a blast in there working, reliable trucks. I wasn't about to stop anyone from that!!! Haha

Already got the new alternator on and it seems to be working pretty damn good. Now I just need to take it out in desert spots by my house before I spend all the money and time trailering it out somewhere. Haha

Sent from my Moto Z (2) using Tapatalk
 
Likes: nebf150
May 7, 2008
5,024
141
63
phoenix, az
replaced the alternator with a NEW NEW NEW brand fucking new alternator, and it seems to of fixed a few things. cant really remeber what all the problems were with it, but yeah. i drove it to and from yoga last night, which is only 5 minutes down the road. but yeah




oh oh oh oh
oh yeah!

so when i first started it and pulled it out of the backyard, seemed fine and everything worked. but when i pulled in the driveway in the front, i noticed that the sniper lcd screen was going kinda wack. it did NOT change anything with how it ran the whole time i was messing with it, but it was as if there was an imaginary finger that would just keep pushing the screen in different places each time. also when i tried to click things, it would work and then the imaginary finger would push something else. it kept going to this screen, then back home, then this screen, blah blah blah. it would stop after a minute or two, then start again. it didnt go any deeper than like 2 screens so it didnt fuck with anything running wise. so i said fuck it, yoga is like 2 minutes down the road. lets go!

runs fine to yoga. get there, park, go inside and do my gay shit - then fuck a class of EXTREMELYYYYYY HOT BITCHES - go to leave and after i started it i checked the screen to see if it was glitching or whatever.......... and it wasnt.
thought about it, what it might have been was that when it did it at home i shut the truck off and on twice..... but i didnt kill the battery/power
until i got to yoga
when i got there, i killed all power then went inside. (came back out after tearing up a bunch of yoga pants inside, literally too - because of anger issues now, not like sex because everyone knows im a flaming faggot fuck hehe, turned the battery back on and it wasnt doing it.............? drove home fine, messed with it when i got home, and i could switch screen to screen without it glitching or anything.

sooooooooo........ i dont fucking know anymore. i dont know when to be happy, mad, sad, pissed off, jack off on the seats, burn it to the ground, i dont fucking know. haha
 
Likes: ucd baja

Latest posts

New Threads

New Classifieds

latest desert trips

Member Builds