4x4 dbl cab tacoma build

Welcome to DezertRangers
Join the community. Register today for all the benefits of membership.
Register

jonsangel

Senior Member
Apr 13, 2009
1,288
225
63
Los Angeles
  • Like
Reactions: yltaco05

jonsangel

Senior Member
Apr 13, 2009
1,288
225
63
Los Angeles
I was so tired after working last weekend I forgot to take pictures. Thanks @the bodj for the help! The motor is officially in! I got the trans in too which in hindsight, i probably should have waited until I got the motor running but whatever. Now I can start the wiring and plumbing
219819

219820


I started draining the 5 year old gas. It didn't seem to be any thicker than normal. I'll probably pull the whole cell and flush it after i get it drained. It felt super sketchy to run that drill pump over a open bucket of gas so I'm only pumping ~2 gallons at a time. My plan is to just let the old gas evaporate so the draining process is going to take me a week or so
219821
 
  • Like
Reactions: MullenFabworks

jonsangel

Senior Member
Apr 13, 2009
1,288
225
63
Los Angeles
I think I have the plumbing figured out. If anyone knows what they're doing please double check what I'm doing

1: "PCV Valve" => Plug (See #6)
2: Connect to #7
3: EVAP => Plug
4: "Steam Tube" => Connect to radiator
5: Connect to oil catch can outlet
6: Connect to oil catch can inlet. Apparently the GTO valve covers have a PCV valve already in them which is why I can just plug #1.
7: Connect to #2
8: Brake Booster
9: HVAC => Plug

219822

219823

219824
 

jonsangel

Senior Member
Apr 13, 2009
1,288
225
63
Los Angeles
Well it looks like I'm going to have to run normal air filters instead of the UMPs due to space. This is what I had in mind for the intake. That piece I'm holding is the MAF
219983


Is there a rule of thumb for the 02 sensor placement? I was thinking of adding it somewhere in here
219984
 

jonsangel

Senior Member
Apr 13, 2009
1,288
225
63
Los Angeles
I got some more motor work done today. I had to weld up some funky fixtures in order to torque down the harmonic balancer pulley without the socket slipping off. It worked great
220313



I mounted the radiator. I didn't realize I bought one set up to push and not pull. It's not ideal but it should work fine. It's definitely sitting where the grill is supposed to be so I'll have to figure something out. I thought that was going to happen but haven't actually mocked it up until now. I'll either have to go to a conversion clip or try and extend the hood/fenders. I'm not sure which I'm leaning towards yet.
220314

220315


I mounted the radiator overflow can, steering cooler, and MAF. All the vacuum lines are plumbed now too.
220317

220316


I started to work on the exhaust but I needed to make cuts with the portable bandsaw so I finally got it mounted. It's not pretty but it's stout. I still need to swap the top plate hardware with some flat heads
220319

220320
 
  • Like
Reactions: ljubera0250

Latest posts

Today's birthdays

New Threads

New Classifieds

latest desert trips

Member Builds