A retarded trophy truck

Welcome to DezertRangers
Join the community. Register today for all the benefits of membership.
Register

84projectford

Senior Member
Sep 8, 2010
2,581
2,554
113
Phoenix Az
Tedious bs today. Got the turbo fully mounted in, oil lines hooked up, drain hooked up and made sure I had clearance everywhere. Then started on the down pipe. It’s against the fender for now till I either cut it or massage the fuck out of it. Brake lines are going to get some sort of heat wrap. Maybe some spark plug shields? Dunno yet.





 

84projectford

Senior Member
Sep 8, 2010
2,581
2,554
113
Phoenix Az
Tedious BS days are the greatest. I have numerous days like that where I work all day and it looks like I got nothing done, but really i got many many steps forward to finish a step of the build.
Its certainly nice once its all done. i had forgotten the time suck that would bring as i wanted to get the downpipe done last night and connected to the rest of the exhaust. oh well, i can knock alot of that out saturday.

Plan is to get it driving by wednesday so i can start tuning for our trip to colorado on July 1st.

Still need to:

move down stream o2 sensors to down pipe and plug old holes in crossover pipe
possibly extend wires for 1 downstreem o2
put in wideband bung in down pipe
finish down pipe
heat wrap down pipe
intercooler tubing
add blow off valve
install check valves where needed
put RR FPR in
put gauges in
mount cruise control box where welder box
move welder to pass front where air box is
put in new power steering res that i broke
get a better afe 7 layer air filter than this chinesium one
set base timing back to 5* at idle, not 13* its at (may shoot for 2* and see if it still runs well or falls on its face at all)
drop 1 colder range on plugs
see if a check engine light is thrown because the MAP sensor is seeing boost, if so, make a map clamp

lots to do!!
 

84projectford

Senior Member
Sep 8, 2010
2,581
2,554
113
Phoenix Az
Boy it was a hot one today but the old swamp cooler kicked ass.

Knocked more shit off the list.

Started with the down pipe. Needed to finish it, add o2 bungs, and put connections in to the rest of the exhaust. The rest of the exhaust is 2.25” so it’s restricted but I’ll change that down the road if it’s an issue. I moved all the down stream o2 sensors to the down pipe. The up stream are still in the crossover pipe as I’ve heard that’s a non issue, the down stream I have no clue and it was easy enough. Wide band is the lowest one. I also massaged the fender for clearance at the down pipe. All is good there




Intercooler tubes up next. Got the turbo to intercooler tube done and realized the damn t-bolt clamps I bought are too small. I went off the “range chart” but nope. So I need new ones for the 2” tube. May just use hose clamps for now




The 2.5” clamps were tight but worked. I tried to make the intercooler to engine pipe all one piece but it won’t work. Can’t get it into the boots so I’ve left a 45* area till a 45* boot shows up. I also wanted to keep the intake manifold crossover tube so I smashed the 2.5 intercooler tube to fit it. Its really not all that bad to make work and won’t impede flow much at all. Also got the blow off valve on and hooked up. Then added the factory air intake temp sensor to post intercooler tube so it can see accurate air intake temps and adjust maps as needed for temps. I’ll be curious what I see for intake temps as well. Had to extend the wires on it quite a bit to make it reach, no biggy.



It’s tight but the regulator has about 1/8” of clearance and the crossover has just a cunt hair of clearance lol.



Finished off the day with putting the raising rate fuel pressure regulator on. Just need some better hose clamps and a vac line and it’s pretty much done. The rrfpr has a single stud on the bottom for mounting and the thing is plastic so I made a little bracket and used a hose clamp as well to support it while I go full retard off road. I’m trying to make everything supported and either have flex or strength to hold up to my abuse.




I really want to start this thing but can’t till I get the power steering resi on Monday. In the mean time, I’ll order up the rest of the little stuff in need. Looking like my test drive won’t be till later this week. Cruise control mounting and welder moving may have to wait till after silverton at the rate shits going. Don’t really need cruise up there anyhow.
 

84projectford

Senior Member
Sep 8, 2010
2,581
2,554
113
Phoenix Az
alright queers, more updates since ive been slackin over posting them the last couple days

It’s alive!

View: https://youtu.be/BrPddGpOxwU


Got the power steering resi moved, added some hose clamps to the fuel lines, put the turbo blanket on and fired her up. Just a small fuel leak at the hard fuel lines as the tube is too big. I’ll do an adapter to that size or change hoses all together.

Yesterday i hammered out more crap.

Got the 45* boot on after massaging the tube a bit, added clamps to the 2” tube out of the turbo, changed the chinsy v-band clamp for a much nicer one, mounted the welder to the pass fender and the coolant resi there as well. Bolted the cruise control down. Put the spark plug heat protectant boots on the brake lines that are by the down pipe. Re-connected welder wiring. And then proceeded to try and build boost in drive. Tried twice and would only get like 1/2 a lbs. then it dawned on me that I never plugged the pcv port nor the open 1/2” tube that goes to the other valve cover . Called it quits there for tonight.

Wasnt going to move the welder but the power steering resi had to get mounted in the area the welder was so off it went. figured i might as well mount the damn cruise control as well (1st world problems). alot of this shit is semi temporary for the whole front end change up that will be coming. i doubt ill even paint some of this shit.

Still need to:
Change crank case vents
Change plugs to colder plugs
Set base timing
Mount gauges
Make a clamp that holds the down pipe to the crossover pipe
Put bushings on steering rack
Fix a stripped skid plate bolt
Warranty out the blown up cv axle





 

84projectford

Senior Member
Sep 8, 2010
2,581
2,554
113
Phoenix Az
Tidied some things up, zip tied parts down, mounted the horns and extended wires for them, trimmed up the grill, put the lights in, set timing to 5*, put a step colder plug in and tighten up the gap a tad, plugged off the throttle body vent hole and I’m just waiting on a few fuel parts tomorrow as well as put the gauges in.

I did start it and let it idle for some time. It sounds like I’ve got exhaust leaks under the turbo either at the turbo flange or the manifold to the head but I’m not sure if it’s just “header type tinging” or actual exhaust leaks. The exhaust has never flowed this way before. I may pull the turbo to verify once everything’s done and I can do a road test. See if it gets worse after or not.

I may have to ditch the center bar for air flow reasons. We will see what air intake temps say with and without the grill driving down the road.

 

84projectford

Senior Member
Sep 8, 2010
2,581
2,554
113
Phoenix Az
The shitastic shit box (full retard TT) preformed extremely well over our vacation up in Silverton. for out-of-the-box running it and extremely small amount of tuning, i really didnt have to do shit to it. i think i have a bad upstream o2 on teh driverside as it kept leaning out on me. i unplugged it, got a check engine light for no o2 heater but she ran titties the rest of the weekend.

Only issues were a leaky exhaust flange at the turbo to manifold. the gasket the chinese wherli boy gave me doesnt fit right so need a different one. And the o2 sensor fucking with me. the RRFPR got a restrictor in the boost reference tube before we left and it wound up being the right size off the bat. Now i can actually adjust the RRFPR to a 4:1 ratio and use it correctly. before it would just peg the fuel pressure out and run rich.

the turbo was a welcome added amount of boost. way more torque at 9k feet compared to last year and no more being stuck in 1st gear 4 lo at the tops of 13k feet passes. instead it was "how fast you wanna go, bitch?". that was fun! Kids approved of boost coming on as well lol.

it dont look like much but last year, in the same place i was lucky to hold 2nd gear, 4lo till i hit the snow, then drop to 1st gear and not go anywhere. this was 3rd gear 4lo, wot and 6k rpm. probably could have held 4th gear but wasnt going to push my luck (damn rev limiter in the passenger seat).


yeah i know, fucking slow and gay as fuck. Just like the owner.

pics from the trip

First ride up to Maggies Gulch



mine at the top of Maggies Gulch



Old ass 2 cyl detroit diesel 2 stroke bull dozer. My son was all about this thing


Rain back at camp. dropped to about 55*


next day at 4th of july parade. They had the LGBQTKSHREOCN club showing what they do best


The fucking fly over by the f35's through the fucking valleys as they flew through town was fucking awesome. straight up goose bumps as 4 flew through like total fucking bad asses. No pics, couldnt get my phone out fast enough

went into town on the 5th and hit up the mayflower mill to show the kids and just cause its bad ass




My boy and my buddies boy trying to pick up the crusher together


Then went to the museum in town and walked about for a couple hours. i could stay in that place all day. so much to read and see. This chain saw was bad ass though


Hit up Animas forks to California pass to hurricane pass a day or so later. Love this drive. 12,950ft at the summit of the pass.




You sit on top of this ridge


After this is where we went playing in the snow with both the kids and vehicles (video is above of vehicles)
 
  • Like
Reactions: Turboyota

84projectford

Senior Member
Sep 8, 2010
2,581
2,554
113
Phoenix Az
We then took a couple days off of wheelin and just fucked around in town, went down and played at the animas, put quarters on the train tracks, bike rides, and a short run up Kendall mountain to see if the old bus was still there (shits gone)

Last wheelin ride was hurricane pass to paughkeepie, down to engineer pass rd when then took us back up to the top of engineer pass and stopped at odom point. this point and imogene pass are my favorite high points to view from.

Comin down Paughkeepie


top of odom point




Overall, a fucking terrible trip.... would not recommend doing this. Full of gay jeeps and gayzers, hot weather, shitty sights, and nothing to do.
 

84projectford

Senior Member
Sep 8, 2010
2,581
2,554
113
Phoenix Az
when we got back, i started into getting the AEM computer to start tuning it and get away from the RRFPR. made sure base timing was correct, hooked the MAF in that i forgot to do years ago, and flashed a base tune in. Cock sucker wouldnt start. kept fucking around with shit and couldnt figure it out. finally, after flashing new .hex files, i got it to start but it was rich as fuck. come to find out, the internal MAP sensor in the AEM aint working right. its at 19.5 psia. no way im making boost at idle but its trying to add 41% more fuel as if i am! im going to try a few different setting and full flashes to make sure its not a corrupt tune but im not hopefull. Course, AEM took down their forum and want an arm and leg to fix it but i did manage to find the same MAP sensor they use and ordered it from Mouser. ill sodler that in and see if that does it. if not, ive got to do a hack work around or something else. real fucking bummer there!

also got a 3 row radiator in today.


that bitch is thick! about 1.5" thicker than stock. suzuki still has the inlet and outlet on the same damn side so you dont get good cross flow so i may see if my buddy can cut my outlet off at the bottom and move it to the opposite side (i cant weld aluminum). only thing that may stop me is the trans heat exchanger is in that area.

Also ordered this bad boy while on the trip and it showed up today. yyyyaaaasssss!!!
 

Latest posts

Today's birthdays

New Threads

New Classifieds

latest desert trips

Member Builds