F2Whiskey Daily Driver Tow Pig F250 SuperDuty

Welcome to DezertRangers
Join the community. Register today for all the benefits of membership.
Register

FasterNU

Mega Member
Jun 28, 2006
8,647
2,623
113
San Diego
Figured I should just make a thread for this pile ... not much fab gonna happen here besides some visual upgrades. But, I did weld on some tabs for an LED.

Here was the old bitch that was replaced. Launched a few spark plugs in that one. haha.



First day I got it home. I found it on April 1st of 2017 ... from Carmax of all places. Not an April fools joke. It's a 2013 with 65K miles. Carmax had front hub caps on rear. brilliant. LOL



First step was I had to remove all the gay decals.











That's right babay. It's a power stroke. Soak it in. lol



An then I had to clean out all door pockets etc.



Enjoyed some of the booty with my mom. haha.



There are some traps in these stupid door panels. Can make some annoying rattles, coins, pens , etc

 

FasterNU

Mega Member
Jun 28, 2006
8,647
2,623
113
San Diego
Second thing was to get some bedliner down in the bed. I used the Custom Coat Spray On liner. I love that stuff.



















 

FasterNU

Mega Member
Jun 28, 2006
8,647
2,623
113
San Diego
Then I drove it for a while... Everything was great up to right around 85,000 miles.....until I had a problem with the trans range sensor(Neutral Safety switch).

It had issues where it wouldn't come out of park. Wouldn't illuminate the P on column. Wouldn't even come out of park if you put key to "On" position. The only way to get it to start was to manually release the shift lock solenoid. At first I suspected that the shift lock solenoid was bad. But I started having problems with the trans not thinking it was in reverse too. Long story short. I paid Convoy Auto $108 to "diagnose" it. They tell me the shift lock solenoid is bad.. and they can't go further without replacing it. And want $300 on top of the $108 to replace it.(it's stupid easy with just a few tools. 20 mins tops) I said I can get that for $90 and do it myself. They said that if that doesn't fix it ... they will charge me another $108 to diagnose further because I did the repairs. At this point, I tell them to suck it, and took it home. I had a feeling it wasn't that solenoid. I replaced it on my own. Didn't change a thing. Fucking WASTE of $108. I'm gonna call them back and talk shit. So, I figured.. has to be trans range sensor AKA neutral safety switch. I buy one. Then when I open it up and start looking for it on outside of trans...I find out.. it's fucking INSIDE the 6r140 trans. Awesome. So, guy buy like $130 in oil and filter for trans.

Drop the pan. Shit's clean in there at least.



See switch up in there. It's pictured in lower center here:



Can't tell how it comes out. Can't seem to find shit about this online. Like I am looking for some top secret weapon plans or something. In hindsight ... I should have looked closer at this picture below... Looking at this was much easier than contorting head up there. But honestly, it's so much easier to see here on a computer. The phone screen didn't show it like this.



I decide to drop the valve body so I can tell what's going on up there.





Turns out... it's just a fucking roll pin inside, and a nut outside. Well, son of a bitch. Don't think I needed to drop the valve body after all!



Moar pics.. seems pretty damn clean in there to me. 85K miles on this. Fluid was a little brownish. So, probably not a bad time to re-fresh fluid and filter anyway.





So, put it all back together. Didn't put new seals on the valve body.. which I think you are technically supposed to?? But DGAF ... it all works now!! Oh yea, and they told me 8 quarts at Oreilly's. Yea right. It was 11 quarts. And I still think I am .5 shy of max full. (Not sure yet. Need to get it real hot.) So.. I bet that fucking solenoid wasn't bad. I am tempted to put old one back in. I am gonna talk shit to auto repair. If they don't want to keep it real.. I will blast them on Yelp. I am 99% sure you can test the trans range sensor separately from shift interlock solenoid.

All that nonsense to replace this...
 

FasterNU

Mega Member
Jun 28, 2006
8,647
2,623
113
San Diego
So, thinking everything was back to normal... I went on a little shopping spree after getting suckered into the Method closeout sale. Couldn't resist.

So, got these wheels for the F2Whiskey! Picked these 18x9's up for only $132/ea. Not bad! They do have -12mm offset... so will stick out a bit. I bought a 2.5" readylift kit for the front. I think I will need to raise rear too actually. (my F250 has the shorter 1-7/8" blocks, not the F350 ones which are closer to 4".)

I wasn't planning any of this.. but the wheels were just too cheap to pass up.



 

FasterNU

Mega Member
Jun 28, 2006
8,647
2,623
113
San Diego
Couldn't stand the ugly valece hanging down from front end... So, trimmed the splitter/valence on the F2Whiskey and then forever blacked it. Re-installed the shortened version to hide the fugly rolled lip with bolts sticking out on bottom edge of bumper.

Much better.. and much blacker! Your mom approves. LOL


Oh, and did a quick test fit... and realized I had to go buy 32x 60* lug nuts too. Snowball mode in full effect. Bought those. Only $20!



 

FasterNU

Mega Member
Jun 28, 2006
8,647
2,623
113
San Diego
Decided while I was at it... to remove the front license plate... and install the Sierra LED I won at Del Mar Tuff trucks a few years ago. Still haven't hooked it up. HAHAH

Actually working on mouting the switch right now...



Found some sweet scrap. The old cock n balls scrap!



Cut his dick off!



I basically took two small flat tabs.. and was able to weld them to existing factor bumper mounts. Here it is mounted.





That may or may not be a K&N hat on the ground I also won at Tuff trucks. haha



 
Last edited:

FasterNU

Mega Member
Jun 28, 2006
8,647
2,623
113
San Diego
So, after spending a bunch of money. The fucking thing decides to throw a code on last Wednesday. Then the next day on Thursday, the day of a huge business meeting.... Both batteries fucking died!

So, had to ride my motorcycle to work. 2x new batteries and $278 later, that problem is fixed. All of this, right before my trip to Pismo to celebrate my Dad's 70th birthday! P0401 is the code. Apparently the EGR coolers clog in these. Parts on order! Stay tuned.

Lift kit arrived that week too.. Looked at it for a bit.



Went to pismo.





All those disco trucks made me shoot home and install it on last Sunday!!





Some specs for you. The front was 34" before lift. The rear was 35". The lift took the front up to 36.5". Obviously, the back is the same. I am going to lift the back to match. Stay tuned on that.

The entire front axle appears to be shifted over 1/4" to the driver side from the factory. This lift shifted it over even more. It shifted over another 1/4"..... so, it is now shifted over 1/2" total. I have an adjustable track bar from Rough Country I ordered to correct that issue. Stay tuned for install. Question is. Do I go to factory spec... or to perfectly centered?

Bought TPMS sensors and tires a day or so ago. I went with 305/70-18 Cooper Discoverer S/T Maxx. It's basically a hybrid 35" tire that is E rated.

I also want to get some of the caster back that I lost. I will get alignment after it's all done. Probably have to force them to sell me cams. haha.
 
Last edited:

garrettw

Member
Mar 23, 2015
132
88
28
San Clemente, CA
Things gonna be cleeaaan with those wheels! What tires are you planning on running? Sometimes you just want to level your daily and put it on 33’s but noooo the snowball effect steps in and wipes out your bank account... now my 4Runner is leveled but rolling on stock 20”s lol
 

FasterNU

Mega Member
Jun 28, 2006
8,647
2,623
113
San Diego
Things gonna be cleeaaan with those wheels! What tires are you planning on running? Sometimes you just want to level your daily and put it on 33’s but noooo the snowball effect steps in and wipes out your bank account... now my 4Runner is leveled but rolling on stock 20”s lol
I posted up the tires I bought. Sheesh. HAHAH JK!

These are what I got:

 

FasterNU

Mega Member
Jun 28, 2006
8,647
2,623
113
San Diego
oh, supposedly rear lift and TPMS show up this weekend.

So, this thing will see those updates soon.

Here is the kit I got for back. ProRyde 3 in 1 blocks. Adjustable to 1.0, 1.5, or 2.0" of lift .... that way I can try it out at different heights before final install.

 
Last edited:

Latest posts

Today's birthdays

New Threads

New Classifieds

latest desert trips

Member Builds